Vai al contenuto principale

Perché vedo l'errore "Questa chiave non consente di visualizzare le informazioni dell'account" in Bitvavo?

Risolvi errore chiave API Bitvavo: abilita permessi "View" e "Trade" corretti per mostrare info account.

Scritto da Bryan
Aggiornato questa settimana

Questo errore significa che la tua API key di Bitvavo non ha i permessi giusti. Nello specifico, il permesso di Accesso in visualizzazione non è abilitato, quindi Cryptohopper non può recuperare le informazioni del tuo account.

Esempio dell'errore nella tua output:

Interfaccia di log degli errori del bot Cryptohopper che mostra errori di connessione API exchange Bitvavo con filtro intervallo di date e dettagli messaggio di errore che mostrano fallimenti nel recupero del saldo

Causa

Quando crei una API key in Bitvavo, devi abilitare permessi specifici. Cryptohopper richiede almeno due permessi per funzionare correttamente:

  • Accesso in visualizzazione — permette a Cryptohopper di recuperare le informazioni del tuo account e del tuo saldo.

  • Trade di asset digitali — permette a Cryptohopper di piazzare ordini di acquisto e vendita.

Questo errore compare quando Accesso in visualizzazione non è abilitato sulla tua API key.

Schermata di configurazione dei diritti di accesso alle API key di Cryptohopper che mostra le opzioni di attivazione per l'accesso in visualizzazione, il trade di asset digitali e il prelievo di asset digitali con il pulsante genera API key

Soluzione

Puoi modificare i permessi della tua API key esistente in Bitvavo, oppure creare una nuova API key con i permessi corretti.

  1. Accedi al tuo account Bitvavo.

  2. Vai alle impostazioni della tua API key.

  3. Assicurati che siaAccesso in visualizzazione che Trade di asset digitali siano abilitati.

  4. Salva le modifiche.

  5. Torna su Cryptohopper e ricollega il tuo exchange Bitvavo utilizzando l'API key aggiornata.

Per istruzioni complete passo-passo sulla creazione e configurazione delle API key di Bitvavo, consulta la nostra guida completa qui.

Verifica la soluzione

Dopo aver ricollegato, controlla il log di output del tuo bot per confermare che l'errore non compaia più.

Hai ricevuto la risposta alla tua domanda?